Aggregate devices audio

  • wildcat80
  • Membro: Expert
  • Risp: 3528
  • Loc: Genova
  • Status:
  • Thanks: 559  

07-09-21 10.38

Domandina insidiosa.
Qualche tempo fa, per tenere un paio di ingressi liberi sulla scheda audio, ho creato un aggregate device con la scheda e la Numa Compact 2x.
Entrambi i dispositivi sono stati settati con la stessa frequenza di campionamento e con una latenza non particolarmente spinta, tipo buffer 256 samples.
Dopo un po' di tempo, in riproduzione o semplice monitoring, si distorceva tutto.
Glitch bestiali. Il problema spariva reinizializzando i devices
Così ho occupato gli ultimi due ingressi con l'uscita audio della Numa e ho risolto il problema, utilizzando solo la UMC1820.
Avete idea di quale possa essere il motivo?
Preciso: MacBook Pro 2015 8/500, SO Catalina, solo un riverbero e una batteria come plugin, tutto il resto audio, DAW Reaper.
  • maxpiano69
  • Membro: Supporter
  • Risp: 20044
  • Loc: Torino
  • Status:
  • Thanks: 2228  

07-09-21 16.12

Non ho mai usato l'Aggregate Device se non per qualche prova estemporanea, ma credo sia critico quale delle schede scegli come master ovvero quale scheda imposti come Clock Source e per quali schede setti la Drift Correction ("Correzione Drift", il flag tutto a destra dell'elenco schede aggregate) e quali no.

Configurare le impostazioni del dispositivo combinato in Configurazione MIDI Audio sul Mac

Abilitare la correzione drift
Se i dispositivi del dispositivo combinato non sono sincronizzati tramite hardware, devi abilitare la correzione drift, anche conosciuta come ricampionamento, per compensare eventuali deviazioni nei dati provenienti dai dispositivi o diretti agli stessi.
(...)
  • wildcat80
  • Membro: Expert
  • Risp: 3528
  • Loc: Genova
  • Status:
  • Thanks: 559  

07-09-21 20.09

Grazie Max ricontrollerò le impostazioni, così su due piedi non ricordo questo passaggio.