Mistero Midi Kurzweil PC4

  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

04-07-24 19.36

Ciao. Ho il seguente problema. Cerco di essere più chiaro possibile
Per una situazione dove suoniamo brani dei Doors, sulla PC4 ho creato una Multi con
un suono di Rhodes che suono sulla PC4 sul canale midi 1
e un suono di organo Vox che suono dal Prologue sul canale midi 7
e tutto funziona regolarmente; il problema è che quando passo da questa Multi ad un altra qualsiasi che NON invia suoni al Prologue, la PC4 continua a inviare al prologue un suono di Piano emo, anche se nella multi che metto il suono di piano non c'è.
Nella modalità program sul canale 7 è settata su None, cioè nessun program.
Ho provato ad usare lo xiosynth al posto del prologue e il problema persiste, avete per caso idea da cosa possa dipendere?emo
  • Acoltemp
  • Membro: Senior
  • Risp: 359
  • Loc: Bari
  • Thanks: 56  

04-07-24 20.16

@ Dantes
Ciao. Ho il seguente problema. Cerco di essere più chiaro possibile
Per una situazione dove suoniamo brani dei Doors, sulla PC4 ho creato una Multi con
un suono di Rhodes che suono sulla PC4 sul canale midi 1
e un suono di organo Vox che suono dal Prologue sul canale midi 7
e tutto funziona regolarmente; il problema è che quando passo da questa Multi ad un altra qualsiasi che NON invia suoni al Prologue, la PC4 continua a inviare al prologue un suono di Piano emo, anche se nella multi che metto il suono di piano non c'è.
Nella modalità program sul canale 7 è settata su None, cioè nessun program.
Ho provato ad usare lo xiosynth al posto del prologue e il problema persiste, avete per caso idea da cosa possa dipendere?emo
Se nella multi la zona del canale 7 la setti in local? (Togliendo dunque il MIDI)?
Forse il none che sarebbe il program 0 viene visto come il primo program dell’altra tastiera (e di solito è un piano)
Non è la Soluzione, ma giusto per cercare via non va.
In ogni caso è strano. Se il canale 7 non è usato nel multi /setup della kurzweil, questa non dovrebbe inviare alcun segnale, in particolare quello di program change.
Nuovo edit: non è che inserisci in ogni multi la zona con canale 7 con il program ‘none’ 0?
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

04-07-24 22.06

@ Acoltemp
Se nella multi la zona del canale 7 la setti in local? (Togliendo dunque il MIDI)?
Forse il none che sarebbe il program 0 viene visto come il primo program dell’altra tastiera (e di solito è un piano)
Non è la Soluzione, ma giusto per cercare via non va.
In ogni caso è strano. Se il canale 7 non è usato nel multi /setup della kurzweil, questa non dovrebbe inviare alcun segnale, in particolare quello di program change.
Nuovo edit: non è che inserisci in ogni multi la zona con canale 7 con il program ‘none’ 0?
il piano che si sente viene dalla kurzweil, sicuro al 100%
in tutte le altre multi non c'è niente sul canale 7, giuro!
  • maxpiano69
  • Membro: Staff
  • Risp: 24942
  • Loc: Torino
  • Thanks: 3415  

05-07-24 06.11

@ Dantes
Ciao. Ho il seguente problema. Cerco di essere più chiaro possibile
Per una situazione dove suoniamo brani dei Doors, sulla PC4 ho creato una Multi con
un suono di Rhodes che suono sulla PC4 sul canale midi 1
e un suono di organo Vox che suono dal Prologue sul canale midi 7
e tutto funziona regolarmente; il problema è che quando passo da questa Multi ad un altra qualsiasi che NON invia suoni al Prologue, la PC4 continua a inviare al prologue un suono di Piano emo, anche se nella multi che metto il suono di piano non c'è.
Nella modalità program sul canale 7 è settata su None, cioè nessun program.
Ho provato ad usare lo xiosynth al posto del prologue e il problema persiste, avete per caso idea da cosa possa dipendere?emo
Premesso che è improprio dire che il PC4 "invia" ma piuttosto "mette a disposizione" un determinato suono su un determinato canale, probabilmente quel setting None non vuol dire "nessun suono" ma "nessun Program Change" e quindi si tiene il suono di default (il piano).

Probabilmente quella parte della Multi va disabilitata (del tutto o almeno rispetto alla tastiera esterna) mediante qualche altro parametro/setting oppure va associata ad un canale MIDI diverso da 7, affinché non suoni.

Se non risolvi altrimenti, prova a creare un Program "muto" monofonico (per non sprecare polifonia) ed assegnargli quello al posto di "None".
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

05-07-24 07.22

@ maxpiano69
Premesso che è improprio dire che il PC4 "invia" ma piuttosto "mette a disposizione" un determinato suono su un determinato canale, probabilmente quel setting None non vuol dire "nessun suono" ma "nessun Program Change" e quindi si tiene il suono di default (il piano).

Probabilmente quella parte della Multi va disabilitata (del tutto o almeno rispetto alla tastiera esterna) mediante qualche altro parametro/setting oppure va associata ad un canale MIDI diverso da 7, affinché non suoni.

Se non risolvi altrimenti, prova a creare un Program "muto" monofonico (per non sprecare polifonia) ed assegnargli quello al posto di "None".
è proprio lì la stranezza, la multi che seleziono dopo quella che mette a disposizione un suono sul canale 7 (allo xiosynth), non ha nessuna zona sul canale 7, ha solo le classiche 4 zone sui canali 1 2 3 4 emo
  • maxpiano69
  • Membro: Staff
  • Risp: 24942
  • Loc: Torino
  • Thanks: 3415  

05-07-24 07.41

@ Dantes
è proprio lì la stranezza, la multi che seleziono dopo quella che mette a disposizione un suono sul canale 7 (allo xiosynth), non ha nessuna zona sul canale 7, ha solo le classiche 4 zone sui canali 1 2 3 4 emo
Uhm... non è che allora che a livello MIDI ci sono sempre 16 parti attive sui canali 1-16 a meno che tu non le usi nella Multi? Prova ad esplicitare in ogni Multi una parte (in ricezione) sul canale 7

Edit: leggendo il manuale Musicians Guide della Pc4 a pag 41. sembra potrebbe essere proprio come pensavo... fai un semplice test, sposta momentaneamente la xiosynth sul canale 6 o 8 e vedi se fa lo stesso, (oppure prova ad inviare un Program Change da xiosynth, dovrebbe cambiare il suono) sarebbe una conferma.

PS: ribadisco il concetto, la PC4 non "trasmette" nulla, è xiosynth trasmette alla PC4 note sul canale 7 e la PC4 per qualche motivo le accetta e ci suona il piano. Non è una finezza lessicale, bisogna avere ben chiaro come funziona il MIDI ed i ruoli di master e slave in ciascuna connessione, se si vuol analizzare e diagnosticare per bene i problemi.
  • Acoltemp
  • Membro: Senior
  • Risp: 359
  • Loc: Bari
  • Thanks: 56  

05-07-24 08.07

@ maxpiano69
Uhm... non è che allora che a livello MIDI ci sono sempre 16 parti attive sui canali 1-16 a meno che tu non le usi nella Multi? Prova ad esplicitare in ogni Multi una parte (in ricezione) sul canale 7

Edit: leggendo il manuale Musicians Guide della Pc4 a pag 41. sembra potrebbe essere proprio come pensavo... fai un semplice test, sposta momentaneamente la xiosynth sul canale 6 o 8 e vedi se fa lo stesso, (oppure prova ad inviare un Program Change da xiosynth, dovrebbe cambiare il suono) sarebbe una conferma.

PS: ribadisco il concetto, la PC4 non "trasmette" nulla, è xiosynth trasmette alla PC4 note sul canale 7 e la PC4 per qualche motivo le accetta e ci suona il piano. Non è una finezza lessicale, bisogna avere ben chiaro come funziona il MIDI ed i ruoli di master e slave in ciascuna connessione, se si vuol analizzare e diagnosticare per bene i problemi.
I canali midi ci sono sempre ovvero sono sempre a disposizione.
Dopo i chiarimenti di Maxpiano, la domanda è: cosa dovrebbe fare la seconda tastiera nelle altre multi?
Al momento, se la multi successiva della kurz ha impostato il KB3 chan su un altro canale (di default l’ 1), la zona canale 7 (utilizzata dalla precedente multi e che ora ha none, nessun -nuovo- strumento) perde tale modalità e suona un program non kb3, come il piano, quando riceve note dall’altra tastiera
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

05-07-24 08.12

@ maxpiano69
Uhm... non è che allora che a livello MIDI ci sono sempre 16 parti attive sui canali 1-16 a meno che tu non le usi nella Multi? Prova ad esplicitare in ogni Multi una parte (in ricezione) sul canale 7

Edit: leggendo il manuale Musicians Guide della Pc4 a pag 41. sembra potrebbe essere proprio come pensavo... fai un semplice test, sposta momentaneamente la xiosynth sul canale 6 o 8 e vedi se fa lo stesso, (oppure prova ad inviare un Program Change da xiosynth, dovrebbe cambiare il suono) sarebbe una conferma.

PS: ribadisco il concetto, la PC4 non "trasmette" nulla, è xiosynth trasmette alla PC4 note sul canale 7 e la PC4 per qualche motivo le accetta e ci suona il piano. Non è una finezza lessicale, bisogna avere ben chiaro come funziona il MIDI ed i ruoli di master e slave in ciascuna connessione, se si vuol analizzare e diagnosticare per bene i problemi.
Sì scusa l'errore di terminologia, mi ero già corretto da solo!
Comunque sì hai ragione, se sulla seconda multi esplicito una parte muted sul canale 7 il problema si risolve.
Certo che è una bella stranezza e sopratutto non capisco perchè va ad associare quel suono di piano.
In modalità program la PC4 trasmette su 16 canali midi e sul canale 7 NON c'è un piano! boh..
Per ora grazie, magari qualcun altro ha avuto lo stesso problema
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

05-07-24 08.14

Acoltemp ha scritto:
Dopo i chiarimenti di Maxpiano, la domanda è: cosa dovrebbe fare la seconda tastiera nelle altre multi?

non dovrebbe fare niente, non dovrebbe ricevere niente
  • Acoltemp
  • Membro: Senior
  • Risp: 359
  • Loc: Bari
  • Thanks: 56  

05-07-24 08.19

@ Dantes
Acoltemp ha scritto:
Dopo i chiarimenti di Maxpiano, la domanda è: cosa dovrebbe fare la seconda tastiera nelle altre multi?

non dovrebbe fare niente, non dovrebbe ricevere niente
Ma mi è parso di comprendere che la usi, visto che senti il piano.
Se così, puoi:
- Non suonarla
- Disattivare nelle altre multi il canale 7 (impostandola in local o il volume a 0)
  • maxpiano69
  • Membro: Staff
  • Risp: 24942
  • Loc: Torino
  • Thanks: 3415  

05-07-24 08.52

Dantes ha scritto:
(...)
se sulla seconda multi esplicito una parte muted sul canale 7 il problema si risolve.
(...)
In modalità program la PC4 trasmette su 16 canali midi e sul canale 7 NON c'è un piano! boh..

Aridaje col "trasmette" emo ... il PC4 "riceve" (Slave)... la master=xiosynth "trasmette" emo emo

Comunque la soluzione è quella li: nelle Multi in cui prevedi di usare la master esterna sul Canale 7, includi sempre una part sul Canale 7 in Mute.
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

05-07-24 09.30

maxpiano69 ha scritto:
Aridaje col "trasmette" ... il PC4 "riceve" (Slave)... la master=xiosynth "trasmette"

emo Hai ragione, so'duro come un pezzo di calcestruzzo emo Comunque nella mia testa il flusso è chiaro..
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

05-07-24 09.38

@ Acoltemp
Ma mi è parso di comprendere che la usi, visto che senti il piano.
Se così, puoi:
- Non suonarla
- Disattivare nelle altre multi il canale 7 (impostandola in local o il volume a 0)
Nelle altre multi ci sono solo 4 zone sui canali 1 2 3 4 quindi mi aspetterei che nessun suono della PC4 fosse disponibile sul canale 7,
ossia: lo xiosynth continua a trasmettere sul canale 7 e la PC4 riceve il segnale midi e produce un suono di piano che non capisco da dove venga
  • Acoltemp
  • Membro: Senior
  • Risp: 359
  • Loc: Bari
  • Thanks: 56  

05-07-24 09.52

@ Dantes
Nelle altre multi ci sono solo 4 zone sui canali 1 2 3 4 quindi mi aspetterei che nessun suono della PC4 fosse disponibile sul canale 7,
ossia: lo xiosynth continua a trasmettere sul canale 7 e la PC4 riceve il segnale midi e produce un suono di piano che non capisco da dove venga
I canali midi (nelle possibilità di ogni tastiera) sono sempre a disposizione.
L’invio di un file midi, ad es. da un software per PC come Reaper, comporta il suonare su kurz di tutti i canali, senza dover scegliere modalità program o multi.
Dunque, per impedirlo (forzando il silenziamento), va attuata una delle due soluzioni prima proposte.
  • pj_korg_tri
  • Membro: Senior
  • Risp: 825
  • Loc: Savona
  • Thanks: 36  

05-07-24 23.03

@ Dantes
Nelle altre multi ci sono solo 4 zone sui canali 1 2 3 4 quindi mi aspetterei che nessun suono della PC4 fosse disponibile sul canale 7,
ossia: lo xiosynth continua a trasmettere sul canale 7 e la PC4 riceve il segnale midi e produce un suono di piano che non capisco da dove venga
ciao
ora non ho il Pc4 sotto mano (e' in sala prove e la uso come unica tastiera); cmq la situazione e' come ha epresso Max (mi pare).
I segnali MIDI all'ingresso del Pc4 (quelli appunto ricevuti dal MIDI In) pilotano i suoni della Multi selezionata e, se il Pc4 riceve segnali su un canale che non e' programmato sulla Multi, il Pc4 "emette" il suono settato sul Mixer (al corrispondente canale MDI , ovviamente).
E' la stessa cosa che avevo riscontrato anche su Artis SE.
Non ho ben capito la filosofia di questa scelta Kurzweil (e devo anche chiarirmi la gestione delle Song, ma questo e' un altro discorso).
  • Dantes
  • Membro: Expert
  • Risp: 2490
  • Loc: Livorno
  • Thanks: 262  

08-07-24 09.53

Comunque la cosa che non mi torna (mistero) è questa
quando accendo il tutto se la PC4 è in modalità Program, lo xiosynth trasmette sul canale 7 e dallo xiosynth suono la PC4 e precisamente il program che è settato sul canale 7 e fin qui non fa una piega.
Passando alla modalità Multi su una classica Multi a 4 zone sui canali 1, 2, 3, 4 lo xiosynth suppongo continui a trasmettere sul canale 7 ma suonando la tastiera dello xiosynth non viene prodotto nessun suono della PC4 (ossia la PC4 non riceve).
Poi,
se seleziono una Multi con una zona sul canale 7 tutto funziona regolarmente e dallo xio suono regolarmente la zona che voglio.
Dopodichè,
se vado a selezionare ancora una Multi classica a 4 zone sui canali 1,2,3,4 la PC4 continua a ricevere dallo xio e produce un suono di piano, cosa che prima sulla Multi classica, non faceva..emo
Per me è questo il mistero..
  • maxpiano69
  • Membro: Staff
  • Risp: 24942
  • Loc: Torino
  • Thanks: 3415  

08-07-24 12.27

@ Dantes
Comunque la cosa che non mi torna (mistero) è questa
quando accendo il tutto se la PC4 è in modalità Program, lo xiosynth trasmette sul canale 7 e dallo xiosynth suono la PC4 e precisamente il program che è settato sul canale 7 e fin qui non fa una piega.
Passando alla modalità Multi su una classica Multi a 4 zone sui canali 1, 2, 3, 4 lo xiosynth suppongo continui a trasmettere sul canale 7 ma suonando la tastiera dello xiosynth non viene prodotto nessun suono della PC4 (ossia la PC4 non riceve).
Poi,
se seleziono una Multi con una zona sul canale 7 tutto funziona regolarmente e dallo xio suono regolarmente la zona che voglio.
Dopodichè,
se vado a selezionare ancora una Multi classica a 4 zone sui canali 1,2,3,4 la PC4 continua a ricevere dallo xio e produce un suono di piano, cosa che prima sulla Multi classica, non faceva..emo
Per me è questo il mistero..
Questo potrebbe essere in effetti un bug della PC4 (il manuale infatti parla di ricezione su tutti e 16 i canali in modalità Program, non Multi), potresti contattare il supporto Kurzweil e sottoporglielo.
  • Acoltemp
  • Membro: Senior
  • Risp: 359
  • Loc: Bari
  • Thanks: 56  

08-07-24 13.43

@ maxpiano69
Questo potrebbe essere in effetti un bug della PC4 (il manuale infatti parla di ricezione su tutti e 16 i canali in modalità Program, non Multi), potresti contattare il supporto Kurzweil e sottoporglielo.
E' una buona idea, così si conferma (o si smentisce, dunque è un bug) la tesi, da me esposta in una delle precedenti mie risposte.