Crepitio scheda audio

  • aiki957
  • Membro: Senior
  • Risp: 280
  • Loc: Catanzaro
  • Status:
  • Thanks: 2  

20-11-21 14.48

Ciao a tutti, ho installato su Linux Mint la daw reaper, ho una scheda audio focusrite 18i8. Suonando con una tastiera master sento dei fastidiosi crepitii come delle interferenze elettriche specialmente se suono più tasti assieme. Non so se è il buffer della scheda per la latenza che è a 512. Ho provato a metterla più alta o più bassa ma non cambia niente. Qualche idea?
  • Jackcats73
  • Membro: Senior
  • Risp: 185
  • Loc: Bologna
  • Status:
  • Thanks: 26  

20-11-21 15.22

@ aiki957
Ciao a tutti, ho installato su Linux Mint la daw reaper, ho una scheda audio focusrite 18i8. Suonando con una tastiera master sento dei fastidiosi crepitii come delle interferenze elettriche specialmente se suono più tasti assieme. Non so se è il buffer della scheda per la latenza che è a 512. Ho provato a metterla più alta o più bassa ma non cambia niente. Qualche idea?
Ciao hai provato come si sente senza scheda audio? Reaper non la conosco ma dovrebbe avere delle impostazioni di latenza.

In alternativa potresti provare Ardour.

Non credo sia la scheda, 512 mi sembra un buffer che non dovrebbe creare problemi e Focusrite è un buon prodotto.
  • Bob_Braces
  • Membro: Senior
  • Risp: 196
  • Loc: Bolzano
  • Status:
  • Thanks: 50  

20-11-21 15.40

@ aiki957
Ciao a tutti, ho installato su Linux Mint la daw reaper, ho una scheda audio focusrite 18i8. Suonando con una tastiera master sento dei fastidiosi crepitii come delle interferenze elettriche specialmente se suono più tasti assieme. Non so se è il buffer della scheda per la latenza che è a 512. Ho provato a metterla più alta o più bassa ma non cambia niente. Qualche idea?
Che server audio usi?
Su linux, è difficile non avere problemi come quelli che descrivi se non sui jack
  • JohnBarleycorn
  • Membro: Expert
  • Risp: 2068
  • Loc: Sassari
  • Status:
  • Thanks: 67  

21-11-21 14.51

@ Bob_Braces
Che server audio usi?
Su linux, è difficile non avere problemi come quelli che descrivi se non sui jack
Confermo, senza il server jack audio (e possibilmente un kernel low latency) avrai problemi di latenza assicurati
  • d_phatt
  • Membro: Expert
  • Risp: 2139
  • Loc: Perugia
  • Status:
  • Thanks: 386  

21-11-21 15.09

@ aiki957
Ciao a tutti, ho installato su Linux Mint la daw reaper, ho una scheda audio focusrite 18i8. Suonando con una tastiera master sento dei fastidiosi crepitii come delle interferenze elettriche specialmente se suono più tasti assieme. Non so se è il buffer della scheda per la latenza che è a 512. Ho provato a metterla più alta o più bassa ma non cambia niente. Qualche idea?
Cosa significa tastiera master? La usi via MIDI per controllare VST o usi i suoni interni della tastiera collegata mandandoli scheda audio?

Se usi una sola applicazione audio alla volta (Reaper) e tutto all'interno di essa, la mancanza di Jack non dovrebbe essere un problema: serve a far comunicare tra loro più software audio a bassa latenza, ma non credo che migliori le prestazioni della singola applicazione.
  • Bob_Braces
  • Membro: Senior
  • Risp: 196
  • Loc: Bolzano
  • Status:
  • Thanks: 50  

21-11-21 15.39

d_phatt ha scritto:
Se usi una sola applicazione audio alla volta (Reaper) e tutto all'interno di essa, la mancanza di Jack non dovrebbe essere un problema: serve a far comunicare tra loro più software audio a bassa latenza, ma non credo che migliori le prestazioni della singola applicazione.


Uhm, nella mia esperienza senza Jack è sostanzialmente impossibile riuscire a gestire la latenza anche di una solo programma audio.
Uso linux pesantemente dalla prima realease di Debian Potato e devo dire a malincuore che dopo 20 anni, nonostante le cose siano migliorate moltissimo, la gestione dell'audio può essere ancora un porcaio. Se azzecchi una combo di hardware standard e ben supportato (non mi riferisco tanto alle schede audio esterne, quelle funzionano quasi tutte, quanto a tutto l'escosistema di bus della mobo), allora ti può capitare un sistema solidissimo, ma se non è così (magari perché hai un laptop nuovo con qualche chipset fresco di produzione). allora rischi di infilarti in un ginepraio.
Poi, come sempre, dipende dalle esigenze. A suonare qualche VST ci si riesce quasi sempre.
  • d_phatt
  • Membro: Expert
  • Risp: 2139
  • Loc: Perugia
  • Status:
  • Thanks: 386  

21-11-21 15.55

@ Bob_Braces
d_phatt ha scritto:
Se usi una sola applicazione audio alla volta (Reaper) e tutto all'interno di essa, la mancanza di Jack non dovrebbe essere un problema: serve a far comunicare tra loro più software audio a bassa latenza, ma non credo che migliori le prestazioni della singola applicazione.


Uhm, nella mia esperienza senza Jack è sostanzialmente impossibile riuscire a gestire la latenza anche di una solo programma audio.
Uso linux pesantemente dalla prima realease di Debian Potato e devo dire a malincuore che dopo 20 anni, nonostante le cose siano migliorate moltissimo, la gestione dell'audio può essere ancora un porcaio. Se azzecchi una combo di hardware standard e ben supportato (non mi riferisco tanto alle schede audio esterne, quelle funzionano quasi tutte, quanto a tutto l'escosistema di bus della mobo), allora ti può capitare un sistema solidissimo, ma se non è così (magari perché hai un laptop nuovo con qualche chipset fresco di produzione). allora rischi di infilarti in un ginepraio.
Poi, come sempre, dipende dalle esigenze. A suonare qualche VST ci si riesce quasi sempre.
Guarda, devo premettere assolutamente che io non ho e non ho mai avuto grandi pretese di produzione. Mi basta poter registrare in alta qualità strumenti esterni, qualche plugin di effetti lo uso ma è sempre in ascolto, insomma la latenza per me non è un problema (tra l'altro tengo il buffer a 512, 2 periodi), non mi serve di suonare in tempo reale con i plugin.

Per cui, lavorando solo con un software, la DAW, uso direttamente ALSA, che poi tanto Jack lo usa comunque come backend di solito, non so su Mint, io uso Debian...e con portatile e fisso, tutti sistemi Intel, non ho mai avuto problemi né con la Focusrite Scarlett prima serie né con la nuova UMC404HD.

Comunque sarebbe necessario sapere cosa sta cercando di fare l'autore del topic, che tipo di collegamenti ha effettuato, se audio o solo MIDI.
  • d_phatt
  • Membro: Expert
  • Risp: 2139
  • Loc: Perugia
  • Status:
  • Thanks: 386  

21-11-21 16.03

@ Bob_Braces
d_phatt ha scritto:
Se usi una sola applicazione audio alla volta (Reaper) e tutto all'interno di essa, la mancanza di Jack non dovrebbe essere un problema: serve a far comunicare tra loro più software audio a bassa latenza, ma non credo che migliori le prestazioni della singola applicazione.


Uhm, nella mia esperienza senza Jack è sostanzialmente impossibile riuscire a gestire la latenza anche di una solo programma audio.
Uso linux pesantemente dalla prima realease di Debian Potato e devo dire a malincuore che dopo 20 anni, nonostante le cose siano migliorate moltissimo, la gestione dell'audio può essere ancora un porcaio. Se azzecchi una combo di hardware standard e ben supportato (non mi riferisco tanto alle schede audio esterne, quelle funzionano quasi tutte, quanto a tutto l'escosistema di bus della mobo), allora ti può capitare un sistema solidissimo, ma se non è così (magari perché hai un laptop nuovo con qualche chipset fresco di produzione). allora rischi di infilarti in un ginepraio.
Poi, come sempre, dipende dalle esigenze. A suonare qualche VST ci si riesce quasi sempre.
Scusa il doppio post di risposta, se dalla DAW bypassi Jack usando direttamente ALSA la latenza peggiora?
  • aiki957
  • Membro: Senior
  • Risp: 280
  • Loc: Catanzaro
  • Status:
  • Thanks: 2  

23-11-21 09.25

@ d_phatt
Scusa il doppio post di risposta, se dalla DAW bypassi Jack usando direttamente ALSA la latenza peggiora?
Premetto che non sono molto pratico con i sistemi Linux, comunque come tastiera ho una Arturia keylab 61 MK2 collegata via USB al PC, anche la Focusrite 18i8 prima serie è ovviamente collegata via USB. Nelle impostazioni di reaper per l'audio ho sulla casella superiore alsa, ed in quella inferiore jack. Nelle caselle più sotto mi compare come interfaccia audio la mia focusrite. Se provo a mettere jack nella prima casella, mi scompare la mia focusrite e non posso più suonare.
  • Bob_Braces
  • Membro: Senior
  • Risp: 196
  • Loc: Bolzano
  • Status:
  • Thanks: 50  

23-11-21 14.47

@ aiki957
Premetto che non sono molto pratico con i sistemi Linux, comunque come tastiera ho una Arturia keylab 61 MK2 collegata via USB al PC, anche la Focusrite 18i8 prima serie è ovviamente collegata via USB. Nelle impostazioni di reaper per l'audio ho sulla casella superiore alsa, ed in quella inferiore jack. Nelle caselle più sotto mi compare come interfaccia audio la mia focusrite. Se provo a mettere jack nella prima casella, mi scompare la mia focusrite e non posso più suonare.
Senza conoscere altri dettagli, ti dico cosa farei io al tuo posto:
- se non li hai già, installi jack e qjackctl
- colleghi scheda audio e master
- apri qjackctl -> "impostazioni" -> "interfaccia" e selezioni la Focusrite. Qui puoi impostare anche buffer, frequenza di campionamento ecc., ricordalo se poi ci sarà da aggiustare qualcosa
- da qjackctrl premi su "Avvia" per far partire jackd
- Apri Reaper e imposti jack come server audio
- Torni in qjackctrl -> "connetti" e verifichi che il routing audio e il routing midi siano impostati correttamente (es: Arturia -> Reaper)
- provi a suonare e vedi che succede
  • d_phatt
  • Membro: Expert
  • Risp: 2139
  • Loc: Perugia
  • Status:
  • Thanks: 386  

24-11-21 10.05

Comunque, Jack o no, non è normale che si sentano rumori strani. Io sia con Jack attivo sia direttamente con ALSA non ho mai avuto questo problema.

Prova anche usare solo ALSA, selezionando l'interfaccia audio giusta e cercando di trovare le migliori impostazioni per il buffer, e vedi se il problema continua a presentarsi.