2 (o piu..) master per 1 ipad (e/o iphone)

  • fusion79it
  • Membro: Senior
  • Risp: 624
  • Loc: Benevento
  • Thanks: 14  

05-09-23 09.23

Buongiorno a tutti. Con un semplice cavo lightning/USB B, ho collegato la novation x-station all'iphone ma non arrivano messaggi midi (dalle uscite audio della tastiera il suono dell'iPhone passa); ho smanettato per circa due ore senza ottenere risultati. C'è un modo per risolvere il problema?
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

05-09-23 09.27

@ fusion79it
Buongiorno a tutti. Con un semplice cavo lightning/USB B, ho collegato la novation x-station all'iphone ma non arrivano messaggi midi (dalle uscite audio della tastiera il suono dell'iPhone passa); ho smanettato per circa due ore senza ottenere risultati. C'è un modo per risolvere il problema?
Di quale "cavo" si tratta? Immagino sia un adattatore e non solo un cavo, comunque se l'audio si sente vuol dire che funziona.

La X-Station la stai usando in modalità Synth o Master? In entrambi i casi devi andare nel menu Template Common e vedere se hai abilitato il MIDI USB (in modalità synth puoi anche farlo dal menu Global)

I dettagli dei vari menu li trovi nel manuale della X-station (meglio leggere che smanettare emo)
  • fusion79it
  • Membro: Senior
  • Risp: 624
  • Loc: Benevento
  • Thanks: 14  

05-09-23 09.37

@ maxpiano69
Di quale "cavo" si tratta? Immagino sia un adattatore e non solo un cavo, comunque se l'audio si sente vuol dire che funziona.

La X-Station la stai usando in modalità Synth o Master? In entrambi i casi devi andare nel menu Template Common e vedere se hai abilitato il MIDI USB (in modalità synth puoi anche farlo dal menu Global)

I dettagli dei vari menu li trovi nel manuale della X-station (meglio leggere che smanettare emo)
Intanto ti ringrazio per la risposta; il cavo in questione funziona con cp 33 e motif es. Da un lato ha l'ingresso per la stampante (dovrebbe essere tipo B maschio), dall'altro è lightning. Mi sono aiutato con il manuale; ho abilitato l'usb midi, ho tentato in modalità master e synth emo
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

05-09-23 10.44

@ fusion79it
Intanto ti ringrazio per la risposta; il cavo in questione funziona con cp 33 e motif es. Da un lato ha l'ingresso per la stampante (dovrebbe essere tipo B maschio), dall'altro è lightning. Mi sono aiutato con il manuale; ho abilitato l'usb midi, ho tentato in modalità master e synth emo
Io ho una X-station 61 che uso da anni con iPad ed adattatore Lighting USB3 ufficiale e funziona tutto, facendo quelle impostazioni. Preferisco evitare di usare roba non ufficiale, può sempre nascondere delle incognite (ma magari non è il tuo caso).

Se vuoi essere aiutato però devi essere (molto) più preciso: quali impostazioni hai fatto esattamente ed in quale menù? Magari fai qualche foto e condividila tramite imgur.

Come approccio alla soluzione, prova a crearti un template dedicato in modalità master, o lavora partendo da uno di quelli di fabbrica per Logic etc. ad esempio che dovrebbero già essere predisposti per andare su USB (ma verificalo) e poi prova a connetterla via USB ad un computer e verifica che sia vista come device MIDI; poi puoi usare un MIDI monitor (MidiOx su Windows, Midi Monitor su Mac) per vedere se manda qualcosa ...
  • fusion79it
  • Membro: Senior
  • Risp: 624
  • Loc: Benevento
  • Thanks: 14  

05-09-23 12.22

@ maxpiano69
Io ho una X-station 61 che uso da anni con iPad ed adattatore Lighting USB3 ufficiale e funziona tutto, facendo quelle impostazioni. Preferisco evitare di usare roba non ufficiale, può sempre nascondere delle incognite (ma magari non è il tuo caso).

Se vuoi essere aiutato però devi essere (molto) più preciso: quali impostazioni hai fatto esattamente ed in quale menù? Magari fai qualche foto e condividila tramite imgur.

Come approccio alla soluzione, prova a crearti un template dedicato in modalità master, o lavora partendo da uno di quelli di fabbrica per Logic etc. ad esempio che dovrebbero già essere predisposti per andare su USB (ma verificalo) e poi prova a connetterla via USB ad un computer e verifica che sia vista come device MIDI; poi puoi usare un MIDI monitor (MidiOx su Windows, Midi Monitor su Mac) per vedere se manda qualcosa ...
Se riesco, in giornata faccio un altro tentativo. La connessione con il Pc funziona, tant'è che in passato importavo preset sulla X-Station. Potrei anche provare ad aggiornare con l'ultimo firmware, potrebbe essere quello il problema. Grazie ancora, ti terrò aggiornato
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

05-09-23 12.26

@ fusion79it
Se riesco, in giornata faccio un altro tentativo. La connessione con il Pc funziona, tant'è che in passato importavo preset sulla X-Station. Potrei anche provare ad aggiornare con l'ultimo firmware, potrebbe essere quello il problema. Grazie ancora, ti terrò aggiornato
Ah si! Se non hai l'ultimo firmware la X-station non è Class Compliant, davo per scontato che lo avessi -> fai l'upgrade.

PS: annotazione, con l'upgrade l'editor della X-Station non funziona più al 100% correttamente per quanto riguarda la creazione dei template (essendo cambiati dei parametri con l'ultimo FW e non esistendo una versione aggiornata dell'editor, almeno su mac, mentre come librarian va ancora bene), è bene saperlo, io a scanso di problemi i template li creo direttamente sulla X-station e poi li importo/esporto in sysex con un librarian generico.
  • fusion79it
  • Membro: Senior
  • Risp: 624
  • Loc: Benevento
  • Thanks: 14  

08-09-23 12.55

@ maxpiano69
Ah si! Se non hai l'ultimo firmware la X-station non è Class Compliant, davo per scontato che lo avessi -> fai l'upgrade.

PS: annotazione, con l'upgrade l'editor della X-Station non funziona più al 100% correttamente per quanto riguarda la creazione dei template (essendo cambiati dei parametri con l'ultimo FW e non esistendo una versione aggiornata dell'editor, almeno su mac, mentre come librarian va ancora bene), è bene saperlo, io a scanso di problemi i template li creo direttamente sulla X-station e poi li importo/esporto in sysex con un librarian generico.
Alla fine ho risolto! piloto i plugin dell'iphone con novation e motif (collegamento con cavo midi). Sono passato per aggiornarti come promesso. Ora devo solo definire le app giuste da scaricare ed imparare ad editare l'uso dei Template su Novation. Grazie ancora!

08-09-23 14.17

@ FoxCT_only_for_sales
Si ho anche io l'originale, ma il mio non ha la ricarica.
Quello originale (oltre a costare 50 euro e va bene), ha una sola entrata.... e quindi devo prevedere Hub, alimentatori e altri cavi (due cojoni!).
Piccolo aggiornamento,
per curiosità oggi ho provato ad alimentare Ipad con un alimentatore più "grosso" (31 watt anzichè i 17), e usando l'adattatore di Amazon, ha funzionato perfettamente.
Probabilmente l'adattatore "assorbe" corrente e i 17 watt erogati dall'Alimentatore standard non sono sufficienti, creando l'effetto batteria che sia carica e non si carica piu'.
Domani faccio la prova del nove e cioè: le tastiere di sempre (Montage e Rd2000) + alimentatore e vediamo se carica.
Ciao!
  • fusion79it
  • Membro: Senior
  • Risp: 624
  • Loc: Benevento
  • Thanks: 14  

08-09-23 17.06

@ maxpiano69
Ah si! Se non hai l'ultimo firmware la X-station non è Class Compliant, davo per scontato che lo avessi -> fai l'upgrade.

PS: annotazione, con l'upgrade l'editor della X-Station non funziona più al 100% correttamente per quanto riguarda la creazione dei template (essendo cambiati dei parametri con l'ultimo FW e non esistendo una versione aggiornata dell'editor, almeno su mac, mentre come librarian va ancora bene), è bene saperlo, io a scanso di problemi i template li creo direttamente sulla X-station e poi li importo/esporto in sysex con un librarian generico.
Un'altra cosa volevo chiederti, approfitto ancora delle tue conoscenze.. da qualche parte ho letto che alimenti l'x-station con iPad; ho tentato con l'iphone ma la tensione non è sufficiente, si accendono solo le quattro spie verdi e rosse accanto al display
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

08-09-23 17.20

@ fusion79it
Un'altra cosa volevo chiederti, approfitto ancora delle tue conoscenze.. da qualche parte ho letto che alimenti l'x-station con iPad; ho tentato con l'iphone ma la tensione non è sufficiente, si accendono solo le quattro spie verdi e rosse accanto al display
Non con l'iPad/iPhone da solo, non ce la fa (la corrente erogabile è limitata a 100mA per non caricare troppo la batteria interna), ma "magia": alimentando l'adattatore Lightning/USB3 con l'alimentatore dell'iPad (o dell'iPhone) invece si fa tranquillamente (perchè il device USB a quel punto è alimentato dall'alimentatore, non più dalla batteria del dispositivo) con il vantaggio che con 1 solo alimentatore alimenti la tastiera + tieni carico l'iPad/iPhone.
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

22-01-24 08.48

@ maxpiano69
Come ci siamo detti, dovrebbe ma va testata, impossibile dirlo con certezza a priori; al max se non va ed il cavo lo hai preso da Amazon, puoi renderlo... altrimenti se hai un amico che ha un laptop con alimentatore con quel tipo di cavo, potresti fartelo prestare per una prova al volo.
Il sistema funziona ma ho notato che ogni tanto, collegando la docking alla rete non si accende (e quindi non alimenta iPad e le due master oltre a non abilitare l’audio .
Tendenzialmente mi pare succeda quando iPad e’ carico rispetto a quando è completamente scarico.
Si può ovviare ?
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

22-01-24 09.45

@ 1paolo
Il sistema funziona ma ho notato che ogni tanto, collegando la docking alla rete non si accende (e quindi non alimenta iPad e le due master oltre a non abilitare l’audio .
Tendenzialmente mi pare succeda quando iPad e’ carico rispetto a quando è completamente scarico.
Si può ovviare ?
Meglio sempre alimentare il dock prima di collegarlo all'iPad, piuttosto che dopo. L'accensione delle master la decide l'iPad quindi è normale che non si accendano finchè non gli colleghi la dock, anche se alimentata.
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

22-01-24 10.54

@ maxpiano69
Meglio sempre alimentare il dock prima di collegarlo all'iPad, piuttosto che dopo. L'accensione delle master la decide l'iPad quindi è normale che non si accendano finchè non gli colleghi la dock, anche se alimentata.
Certo, la docking alimenta tutto il resto ma il problema e’ che ogni tanto non si accende quando la collego alla rete; proverò come hai detto a collegarla alla rete e solo dopo all’iPad.
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

22-01-24 16.56

@ maxpiano69
Meglio sempre alimentare il dock prima di collegarlo all'iPad, piuttosto che dopo. L'accensione delle master la decide l'iPad quindi è normale che non si accendano finchè non gli colleghi la dock, anche se alimentata.
Ho provato a collegare la docking alla rete senza collegarla ad IPad ma non si accende lo stesso. Boh?
  • maxpiano69
  • Membro: Staff
  • Risp: 24170
  • Loc: Torino
  • Thanks: 3274  

22-01-24 19.21

@ 1paolo
Ho provato a collegare la docking alla rete senza collegarla ad IPad ma non si accende lo stesso. Boh?
Come ti ho scritto, è normale, è l'host (in questo caso l'iPad) che da l'OK ad accendersi ai dispositivi, sia all'hub stesso che quelli ad esso collegati.
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

11-02-24 11.37

@ maxpiano69
Come ti ho scritto, è normale, è l'host (in questo caso l'iPad) che da l'OK ad accendersi ai dispositivi, sia all'hub stesso che quelli ad esso collegati.
Ok Max avevo problemi sulla riduzione della presa; adesso, facendo come dici, prima collego la doking e dopo l’iPad, tutto funzionaemo
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

19-02-24 13.29

@ 1paolo
Ok Max avevo problemi sulla riduzione della presa; adesso, facendo come dici, prima collego la doking e dopo l’iPad, tutto funzionaemo
Ho appena preso un IPhone SE e ho intenzione di inserto nel home studio come fosse un expander.
  • Ovidio
  • Membro: Senior
  • Risp: 211
  • Loc:
  • Thanks: 41  

19-02-24 14.23

@ 1paolo
Ho appena preso un IPhone SE e ho intenzione di inserto nel home studio come fosse un expander.
Io ne ho uno da vendere (Iphone SE 2016), se interessa a qualche forumer.
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

19-02-24 14.40

@ Ovidio
Io ne ho uno da vendere (Iphone SE 2016), se interessa a qualche forumer.
Ovidio metti un annuncio (mercatino) sul forum e su Subito.it, con indicazione del prezzo; e’ un buon telefono, affidabile e di dimensioni compatte, dovresti venderlo facilmente ..emo
  • 1paolo
  • Membro: Guru
  • Risp: 4854
  • Loc: Cuneo
  • Thanks: 586  

19-02-24 15.24

@ maxpiano69
Come ti ho scritto, è normale, è l'host (in questo caso l'iPad) che da l'OK ad accendersi ai dispositivi, sia all'hub stesso che quelli ad esso collegati.
L’iPhone SE ha l’uscita “ piccola” come aveva il precedente iPhone 6.
Per collegarlo alla docking mi basta un adattatore USB-a > Usb-c? Grazie 🙏